Commit 46e9656d authored by Administrator's avatar Administrator

dependency update, bugfix: power dump, bugfix: missing flushbar

parent 601d1cfb
This diff is collapsed.
......@@ -22,22 +22,8 @@ class _ActivitiesListWidgetState extends State<ActivitiesListWidget> {
@override
initState() {
getActivities();
if (widget.athlete.email == null) {
Flushbar(
message: "Strava email not provided yet!",
duration: Duration(seconds: 3),
backgroundColor: Colors.red,
)..show(context);
}
if (widget.athlete.password == null) {
Flushbar(
message: "Strava password not provided yet!",
duration: Duration(seconds: 3),
backgroundColor: Colors.red,
)..show(context);
}
WidgetsBinding.instance
.addPostFrameCallback((_) => showMyFlushbar());
super.initState();
}
......@@ -223,4 +209,21 @@ class _ActivitiesListWidgetState extends State<ActivitiesListWidget> {
],
);
}
showMyFlushbar() {
if (widget.athlete.email == null) {
Flushbar(
message: "Strava email not provided yet or not a Strava User!",
duration: Duration(seconds: 3),
backgroundColor: Colors.yellow[900],
)..show(context);
}
else if(widget.athlete.password == null) {
Flushbar(
message: "Strava password not provided yet!",
duration: Duration(seconds: 3),
backgroundColor: Colors.red,
)..show(context);
}
}
}
......@@ -34,9 +34,9 @@ class _ActivityPowerWidgetState extends State<ActivityPowerWidget> {
var powerRecords = records
.where((value) => value.db.power != null && value.db.power > 100)
.toList();
var lastRecord = powerRecords.last;
if (powerRecords.length > 0) {
var lastRecord = powerRecords.last;
return ListTileTheme(
iconColor: Colors.deepOrange,
child: ListView(
......
......@@ -7,14 +7,14 @@ packages:
name: _fe_analyzer_shared
url: "https://pub.dartlang.org"
source: hosted
version: "1.0.1"
version: "2.2.0"
analyzer:
dependency: transitive
description:
name: analyzer
url: "https://pub.dartlang.org"
source: hosted
version: "0.39.2+1"
version: "0.39.7"
archive:
dependency: transitive
description:
......@@ -56,35 +56,35 @@ packages:
name: build_config
url: "https://pub.dartlang.org"
source: hosted
version: "0.4.1+1"
version: "0.4.2"
build_daemon:
dependency: transitive
description:
name: build_daemon
url: "https://pub.dartlang.org"
source: hosted
version: "2.1.3"
version: "2.1.4"
build_resolvers:
dependency: transitive
description:
name: build_resolvers
url: "https://pub.dartlang.org"
source: hosted
version: "1.3.0"
version: "1.3.7"
build_runner:
dependency: "direct dev"
description:
name: build_runner
url: "https://pub.dartlang.org"
source: hosted
version: "1.7.3"
version: "1.9.0"
build_runner_core:
dependency: transitive
description:
name: build_runner_core
url: "https://pub.dartlang.org"
source: hosted
version: "4.3.0"
version: "5.1.0"
build_verify:
dependency: "direct dev"
description:
......@@ -105,7 +105,7 @@ packages:
name: built_value
url: "https://pub.dartlang.org"
source: hosted
version: "7.0.4"
version: "7.1.0"
charcode:
dependency: transitive
description:
......@@ -168,7 +168,7 @@ packages:
name: coverage
url: "https://pub.dartlang.org"
source: hosted
version: "0.13.3+3"
version: "0.13.9"
crypto:
dependency: transitive
description:
......@@ -203,7 +203,7 @@ packages:
name: dart_style
url: "https://pub.dartlang.org"
source: hosted
version: "1.3.3"
version: "1.3.6"
datetime_picker_formfield:
dependency: "direct main"
description:
......@@ -217,7 +217,7 @@ packages:
name: dio
url: "https://pub.dartlang.org"
source: hosted
version: "3.0.8"
version: "3.0.9"
dio_cookie_manager:
dependency: "direct main"
description:
......@@ -257,14 +257,14 @@ packages:
name: flutter_launcher_icons
url: "https://pub.dartlang.org"
source: hosted
version: "0.7.4"
version: "0.7.5"
flutter_secure_storage:
dependency: "direct main"
description:
name: flutter_secure_storage
url: "https://pub.dartlang.org"
source: hosted
version: "3.3.1+1"
version: "3.3.3"
flutter_test:
dependency: "direct dev"
description: flutter
......@@ -309,14 +309,14 @@ packages:
name: http_multi_server
url: "https://pub.dartlang.org"
source: hosted
version: "2.1.0"
version: "2.2.0"
http_parser:
dependency: transitive
description:
name: http_parser
url: "https://pub.dartlang.org"
source: hosted
version: "3.1.3"
version: "3.1.4"
image:
dependency: transitive
description:
......@@ -337,7 +337,7 @@ packages:
name: io
url: "https://pub.dartlang.org"
source: hosted
version: "0.3.3"
version: "0.3.4"
js:
dependency: transitive
description:
......@@ -358,7 +358,7 @@ packages:
name: logging
url: "https://pub.dartlang.org"
source: hosted
version: "0.11.3+2"
version: "0.11.4"
matcher:
dependency: transitive
description:
......@@ -414,7 +414,7 @@ packages:
name: package_config
url: "https://pub.dartlang.org"
source: hosted
version: "1.1.0"
version: "1.9.3"
package_resolver:
dependency: transitive
description:
......@@ -477,7 +477,7 @@ packages:
name: plugin_platform_interface
url: "https://pub.dartlang.org"
source: hosted
version: "1.0.1"
version: "1.0.2"
pool:
dependency: transitive
description:
......@@ -498,7 +498,7 @@ packages:
name: pub_semver
url: "https://pub.dartlang.org"
source: hosted
version: "1.4.2"
version: "1.4.4"
pubspec_parse:
dependency: transitive
description:
......@@ -519,28 +519,28 @@ packages:
name: shared_preferences
url: "https://pub.dartlang.org"
source: hosted
version: "0.5.6"
version: "0.5.7"
shared_preferences_macos:
dependency: transitive
description:
name: shared_preferences_macos
url: "https://pub.dartlang.org"
source: hosted
version: "0.0.1+3"
version: "0.0.1+7"
shared_preferences_platform_interface:
dependency: transitive
description:
name: shared_preferences_platform_interface
url: "https://pub.dartlang.org"
source: hosted
version: "1.0.1"
version: "1.0.3"
shared_preferences_web:
dependency: transitive
description:
name: shared_preferences_web
url: "https://pub.dartlang.org"
source: hosted
version: "0.1.2+2"
version: "0.1.2+4"
shelf:
dependency: transitive
description:
......@@ -580,7 +580,7 @@ packages:
name: source_gen
url: "https://pub.dartlang.org"
source: hosted
version: "0.9.4+7"
version: "0.9.5"
source_map_stack_trace:
dependency: transitive
description:
......@@ -594,7 +594,7 @@ packages:
name: source_maps
url: "https://pub.dartlang.org"
source: hosted
version: "0.10.8"
version: "0.10.9"
source_span:
dependency: transitive
description:
......@@ -608,21 +608,28 @@ packages:
name: sqfentity
url: "https://pub.dartlang.org"
source: hosted
version: "1.2.3+1"
version: "1.3.4+1"
sqfentity_gen:
dependency: "direct main"
description:
name: sqfentity_gen
url: "https://pub.dartlang.org"
source: hosted
version: "1.2.3+3"
version: "1.3.4+3"
sqflite:
dependency: transitive
description:
name: sqflite
url: "https://pub.dartlang.org"
source: hosted
version: "1.2.0"
version: "1.3.0"
sqflite_common:
dependency: transitive
description:
name: sqflite_common
url: "https://pub.dartlang.org"
source: hosted
version: "1.0.0+1"
stack_trace:
dependency: transitive
description:
......@@ -650,7 +657,7 @@ packages:
name: stream_transform
url: "https://pub.dartlang.org"
source: hosted
version: "1.1.0"
version: "1.2.0"
string_scanner:
dependency: transitive
description:
......@@ -664,7 +671,7 @@ packages:
name: synchronized
url: "https://pub.dartlang.org"
source: hosted
version: "2.1.1"
version: "2.2.0"
term_glyph:
dependency: transitive
description:
......@@ -720,28 +727,28 @@ packages:
name: url_launcher
url: "https://pub.dartlang.org"
source: hosted
version: "5.4.1"
version: "5.4.5"
url_launcher_macos:
dependency: transitive
description:
name: url_launcher_macos
url: "https://pub.dartlang.org"
source: hosted
version: "0.0.1+2"
version: "0.0.1+5"
url_launcher_platform_interface:
dependency: transitive
description:
name: url_launcher_platform_interface
url: "https://pub.dartlang.org"
source: hosted
version: "1.0.5"
version: "1.0.6"
url_launcher_web:
dependency: transitive
description:
name: url_launcher_web
url: "https://pub.dartlang.org"
source: hosted
version: "0.1.0+2"
version: "0.1.1+2"
uuid:
dependency: "direct main"
description:
......@@ -769,7 +776,7 @@ packages:
name: watcher
url: "https://pub.dartlang.org"
source: hosted
version: "0.9.7+13"
version: "0.9.7+15"
web_socket_channel:
dependency: transitive
description:
......@@ -792,5 +799,5 @@ packages:
source: hosted
version: "2.2.0"
sdks:
dart: ">=2.6.0 <3.0.0"
dart: ">=2.7.0 <3.0.0"
flutter: ">=1.12.13+hotfix.5 <2.0.0"
......@@ -23,7 +23,7 @@ dependencies:
charts_flutter: ^0.8.1
uuid: 2.0.4
flushbar: ^1.9.1
flushbar: 1.9.1
path_provider: ^1.6.7
csv: ^4.0.3
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment